FAQ (Ελληνικά)

From ParabolaWiki
Jump to: navigation, search

i18n


Dansk – Deutsch – English – Esperanto – Español – Euskera – Français – Galego – Indonesia – Italiano – Lietuviškai – Magyar – Nederlands – Polski – Português – Română – Slovenský – Suomi – Svenska – Türkçe – Česky – Ελληνικά – Български – Русский – Српски – Українська – العربيّة – עברית – ไทย – 日本語 – 正體中文 – 简体中文 – 한국어

Αυτό το άρθρο έχει σκοπό να δώσει απαντήσεις σε ερωτήσεις που υποβάλλονται συχνά από τους χρήστες που μετακομίζουν στο Parabola από το Arch ή και άλλες μη-ελεύθερες διανομές GNU/Linux. Ασχολείται με ζητήματα που προκαλούνται όταν το σύστημά είναι εντελώς ελέυθερο. Για την εξήγηση σχετικά με τις τεχνικές λεπτομέρειες του συστήματος ανατρέξτε στο Arch FAQ.

1 Πακέτα Λογισμικού

1.1 Γιατί το πακέτο X λείπει, αν και είναι διαθέσιμο στο Arch;

Αυτό συνήθως σημαίνει ότι το πακέτο είναι μη-ελεύθερο ή έχει κάποια άλλα σχετικά ζητήματα. Επειδή το Parabola ακολουθεί τίς Κατευθυντήριες Γραμμές Διανομής Ελέυθερων Συστημάτων GNU, δεν περιλαμβάνει ιδιόκτητο λογισμικό και συνεπώς δεν μπορείτε να το βρείτε από τα επίσημα αποθετήρια. Για να βεβαιωθείτε ότι το πακέτο είχε αφαιρεθεί από το Parabola, μπορείτε να ελέγξετε τη μαύρη λίστα:

$ grep το_όνομα_του_πακέτου /usr/share/doc/your-freedom/blacklist.txt

1.2 Πώς είναι το πακέτο X διαφορετικό από το αντίστοιχο στο Arch;

Τα πακέτα συνήθως τροποποιούνται για κάποιους λόγους, όπως για παράδειγμα περιέχει μη-ελέυθερα μέρη, συνιστά μη-ελεύθερο λογισμικό ή έχει εμπορικά σύμβολα. Για να μάθετε πώς το συγκεκριμένο πακέτο τροποποιήθηκε ελέγξτε τη μαύρη λίστα:

$ grep το_όνομα_του_πακέτου /usr/share/doc/your-freedom/blacklist.txt

Αν ψάχνετε για περισσότερες λεπτομέρειες, θα πρέπει να κάνετε clone το αποθετίριο abslibre.git που περιέχει τα αρχεία PKGBUILD που χρησιμοποιούνται για την οικοδόμηση τών πακέτων στο [libre]. Κατεβάστε το αντίστοιχο PKGBUILD από την ιστοσελίδα του Arch και τρέξτε την εντολή diff και στα δυο.

1.3 Γιατί λαμβάνω μήνυμα σφάλματος σχετικά ότι λείπει μία κοινόχρηστη βιβλιοθήκη (shared library);

Ορισμένα προγράμματα χρειάζονται μια συγκεκριμένη έκδοση της βιβλιοθήκης που χρησιμοποιούν. Όταν η βιβλιοθήκη λαμβάνει αναβάθμιση στο Arch, μετά από κάποιο χρονικό διάστημα ο διακομιστής του Parabola συγχρονίζεται και τα προγράμματα που εξαρτώνται από την προηγούμενη έκδοση της βιβλιοθήκης δέν λειτουργούν.

Εκτός αν είστε χάκερ (προγραμματιστής) του Parabola είναι καλύτερο να υποβαθμίσετε την έκδοση της βιβλιοθήκης που έλαβε την αναβάθμιση και ενημερώστε τους χάκερ του Parabola σχετικά με το θέμα. Ο προτιμώμενος τρόπος για να ανοίξετε ένα νέο θέμα είναι το issue tracker (αγγλόφωνο).

1.4 Θα έχουν αφαιρεθεί τα μη-ελέυθερα πακέτα του AUR μετά τη μετεγκατάσταση στο Parabola;

Όχι. Το Parabola δεν υποστηρίζει το AUR με οποιοδήποτε τρόπο. Μετά τη μετεγκατάσταση στο Parabola θα πρέπει να ελεγκτούν όλα τα εγκατεστημένα πακέτα του AUR και να διαγράψετε τα μη-ελέυθερα. Από το AUR τα πακέτα συνήθως συναρμολογούνται και εγκαταστείθωνται από τον χρήστη, γ' αυτό μπορείτε να τα αναγνωρίσετε τρέχοντας:

$ pacman -Qm

Μερικά πακέτα του AUR συγχονέυωνται στο αποθετήριο του Parabola [pcr]. Εάν δεν μπορείτε να βρείτε το πακέτο που χρειάζεστε, ζητήστε από ένα χάκερ να το βάλει.

Ένας χρήστης υπέβαλε αίτηση για να δημιουργηθεί μαύρη λίστα για το AUR, αλλά προφανώς λίγη δουλειά έγινε. Για περισσότερες λεπτομέρειες δείτε το bug report και την ημιτελή μάυρη λίστα.

1.5 Το LaTeX εκτυπώνει μηνύματα σφάλματος σχετικά με γραμματοσειρές που λείπουν. Πώς μπορώ να καταρτίσω το έγγραφο μου;

Ορισμένες γραμματοσειρές έχουν αφαιρεθεί από τη διανομή TeX Live, λόγω θεμάτων ελευθερίας και ασυμβίβαστων άδειων (license). Μια λύση σε αυτό είναι να χρησιμοποιήσετε άλλες γραμματοσειρές ή/και άλλο engine για TeX. Για περισσότερες πληροφορίες δείτε το TeXLive.

1.6 Πώς μπορώ να εξαγάγω ένα αρχείο RAR;

Η εντολή unrar λείπει στο Parabola, επειδή είναι μη-ελεύθερο λογισμικό. Μπορείτε να χρησιμοποιήσετε την εντολή bsdtar. Θα πρέπει να είναι ήδη εγκατεστημένη στο σύστημά σας, γιατί το pacman εξαρτάται από το libarchive το οποιό την παρέχει. Δυστυχώς, δεν μπορεί να χειριστεί κάποια επιπλέον χαρακτηριστικά των αρχείων RAR, στην οποία περίπτωση μπορεί να δοκιμάσετε το unar.

2 Συσκεύες

2.1 Γιατί η κάρτα γραφικών Nvidia δεν δουλέυει;

Αυτό μπορεί να συμβεί εάν έχετε μια πρόσφατη κάρτα Nvidia. Ο οδηγός Nouveau μπορεί να μην υποστηρίζει την κάρτα ακόμα. Για να ελέγξετε αν η κάρτα σας υποστηρίζεται από το Nouveau, πρώτα αναζητήστε τον κωδικό της κάρτας σας:

$ lspci | grep VGA

Μετά, κοιτάξτε στο CodeNames για περαιτέρω αποκωδικοποιήση. Τέλος, μπορείτε να ελέγξετε την υποστήριξη της κάρτα σας στο FeatureMatrix.

2.2 Γιατί η κάρτα Wi-Fi σταμάτησε να λειτουργεί μετά την μετεγκατάσταση;

Είναι συνηθές για κάρτες Wi-Fi να απαιτούν φόρτωση λογισμικού οδηγού. Πολλές κάρτες δεν λειτουργούν καθόλου αν ο οδήγος λείπει, το οποιό είναι συχνά ιδιόκτητο, έτσι δεν μπορούμε να το διανέμουμε. Αυτή είναι η περίπτωση για σχεδόν οποιαδήποτε εσωτερική κάρτα Wi-Fi.

Η συνήθης λύση για το πρόβλημα είτε για να αντικαταστήσετε την κάρτα ή να χρησιμοποιήσετε ένα εξωτερικό USB Wi-Fi dongle. Μπορείτε να αγοράσετε ένα με Atheros chipset (π.χ. ath9k_htc για εξωτερικό USB dongle ή ath9k για PCI και PCI-Express υποδοχές επέκτασης) ή RTL818x chipset (π.χ. rtl8187 για εξωτερικό USB dongle ή rtl818x_pci για PCI και PCI-Express υποδοχές επέκτασης) δεδομένου ότι υπάρχει ένα ελεύθερο λογισμικό οδηγού για αυτά τα Wi-Fi adapters. Μπορείτε επίσης να αναζητήσετε στην h-node βάση δεδομένων για να βρείτε Wi-Fi adapters που είναι γνωστό να λειτουργούν καλά με ελεύθερο λογισμικό ή scripts/deblob-$ver για να ελέγξετε τα Wi-Fi adapters που περιλαμβάνονται στην μαύρη λίστα και είναι γνωστό ότι δεν δουλέυουν με ελεύθερο λογισμικό, επειδή περιέχουν δυαδικό λογισμικό από το εσωτερικό των exploded Linux source trees.