FAQ (Українська)

From ParabolaWiki
Jump to: navigation, search

i18n


Dansk – Deutsch – English – Esperanto – Español – Euskera – Français – Galego – Indonesia – Italiano – Lietuviškai – Magyar – Nederlands – Polski – Português – Română – Slovenský – Suomi – Svenska – Türkçe – Česky – Ελληνικά – Български – Русский – Српски – Українська – العربيّة – עברית – ไทย – 日本語 – 正體中文 – 简体中文 – 한국어

Метою цієї статті є надання відповідей на запитання, які часто задають користувачі, які перейшли до Parabola з Arch та інших невільних дистрибутивів GNU/Linux. Вона обговорює питання, викликані тим, що система повністю вільна. Для пояснення технічних деталей системи зверніться до Arch FAQ.

1 Пакети

1.1 Чому пакет X відсутній, навіть якщо він доступний у Arch?

Зазвичай це означає, що пакет не є вільним або має деякі інші проблеми, пов'язані з свободою. Оскільки Parabola слідує FSDG(оригінал), ми не включаємо пропрієтарне програмне забезпечення, і ви не можете отримати його з офіційних репозиторіїв. Щоб переконатися, що пакет було видалено з Parabola через це, ви можете перевірити чорний список:

$ grep package_name /usr/share/doc/your-freedom/blacklist.txt

1.2 Як різниця між пакетом X у репозиторіях Parabola та ArchLinux?

Пакети зазвичай змінюються через те, що вони містять невільні частини, рекомендують невільне програмне забезпечення або брендинг. Щоб дізнатися, як було змінено певний пакет, перевірте чорний список:

$ grep package_name /usr/share/doc/your-freedom/blacklist.txt

Якщо ви шукаєте більш детальну інформацію, вам доведеться клонувати abslibre.git, що містить файли PKGBUILD, які використані для створення пакунків у репозиторії [libre]. Візьміть відповідний PKGBUILD з веб-сайту Arch та просто запустіть diff для обох.

1.3 Чому я отримую помилку через відсутність спільної бібліотеки?

Деякі програми потребують певної версії бібліотеки, яку вони використовують. Коли бібліотека отримує оновлення в Arch, через деякий час вона потрапляє на сервер Parabola і програми, які залежать від попередньої версії бібліотеки перестають працювати.

Якщо ви не є хакером Parabola, краще всього відновити залежність, яка отримала оновлення, і повідомити про це хакерам Parabola. Переважною формою є створення нового питання на трекері.

1.4 Чи будуть видалені невільні пакети з AUR після переходу на Parabola?

Ні. Parabola жодним чином не підтримує AUR. Після переходу на Parabola вам доведеться перевірити будь-який встановлений пакет AUR і вручну видалити невільні. Оскільки пакети AUR, як правило, створюються та встановлюються користувачем, їх можна ідентифікувати за допомогою:

$ pacman -Qm

Деякі пакунки AUR знаходяться в офіційному сховищі Parabola з ім'ям [pcr]. Якщо ви не можете знайти потрібний пакунок, попросіть хакера додати його до репозиторіїв Parabola, або у списку розсилки або у розділі "запити на додавання пакета" на баг-трекері, вони можуть допомогти визначити, чи відповідає він стандартам FSDG(оригінал).

Якийсь користувач попросив створити чорний список для AUR, але, очевидно, мало було зроблено для цього. Для більш детальної інформації зверніться на трекер помилок та до незавершеного чорного списку AUR.

1.5 LaTeX виводить помилки про відсутні шрифти. Як я можу створити свій документ без них?

Деякі шрифти були видалені з нашої версії TeX Live через проблеми з свободою та несумісними ліцензіями. Рішенням цього є використання інших шрифтів та/або різних реалізацій TeX. Для більшої інформації дивіться TeXLive.

1.6 Як розпакувати RAR архів?

Команда unrar відсутня в Parabola, тому що це не вільне програмне забезпечення. Ви можете використовувати команду bsdtar для розпакування. Вона повинна бути встановлена у вашій системі за замовчуванням, тому що pacman залежить від libarchive, який його надає. На жаль, він не може працювати з деякими додатковими функціями архівів RAR, і в цьому випадку вам може більше підійти unar.

1.7 Чому я не можу оновити пакети?

Дивіться усунення несправностей Pacman

2 Апараті засоби

2.1 Чому моя відеокарта Nvidia не працює?

Це може статися, якщо у вас нова карта від Nvidia. Драйвер nouveau може не підтримувати вашу карту. Щоб перевірити, чи підтримується ваша картка драйвером nouveau, спочатку знайдіть кодове ім'я своєї картки за допомогою команди:

$ lspci | grep VGA

Далі зверніться до списку кодових імен для подальшого розкодування. Після цього ви можете перевірити підтримку своєї картки за допомогою цієї таблиці.

2.2 Чому після переходу моя Wi-Fi карта перестала працювати?

Для Wi-Fi карт зазвичай потрібно, щоб на неї було завантажено мікропрограму. Багато карт взагалі не працюють, якщо прошивка відсутня. Прошивка часто є закритою, тому ми її не розповсюджуємо. Це стосується практично будь-якої внутрішньої Wi-Fi карти.

Найпростішне рішення - це замінити карту або купити зовнішній USB Wi-Fi адаптер, який суміснпий з вільним програмним забезпеченням. Ви можете купити один з чіпсетом:

Atheros:

RTL818x:

Ви також можете шукати в базі даних h-node, щоб знайти адаптери Wi-Fi, які добре працюють з вільним програмним забезпеченням або використати скрипт deblob-$ver для перевірки Wi-Fi-адаптерів, включених до чорного списку пристроїв, відомо, що вони не працюють з вільним програмним забезпеченням, яке не містить блоби(blobs) в Linux. Або перевірте список комплектуючих Respect Your Freedom , який містить безліч зовнішніх і внутрішніх адаптерів Wi-Fi, які сумісні з вільним програмним забезпеченням.